Sky and weather but no image

YoWindow widget Questions, Suggestions and Bugs
westhag1943
Posts: 5
Joined: Wed Apr 06, 2016 4:26 pm
Name: Roger John Sweet

Sky and weather but no image

Post by westhag1943 » Wed Apr 06, 2016 5:01 pm

I've created a background for the location "Aldbourne" and saved it as yo_weather.png and included it in the landscapes folder in the root directory for the website (landscapes/weather (which contains weather.ywl and yo_weather.png)). I've tried to follow the instructions for using my own background but all I see is sky and weather, i.e. no image of Aldbourne.

This is the link to my webpage: http://berkshiredownsvillages.co.uk/Wea ... ravel.html

This is the relevant piece of code I've changed:
<param name="flashvars"
value="location_id=gn:2657562&location_name=Aldbourne&time_format=12&unit_system=uk&landscape=http://www.berkshirevillages.co.uk/land ... eather.ywl"
/>

Can anyone help please?

User avatar
Wally©
Posts: 805
Joined: Sun Dec 12, 2010 2:18 am
Name: Walter

Re: Sky and weather but no image

Post by Wally© » Wed Apr 06, 2016 7:23 pm

1. Does the root of the server contain the .xml file..?

2. Does the weather.ywl file have reference to the actual .swf file which holds the landscape image..?

I've tried to access the .ywl file and it says it's not even there...neither is the .swf image file...
Wally©...

(Ignorance can easily be overcome...Stupidity is 4ever...)

westhag1943
Posts: 5
Joined: Wed Apr 06, 2016 4:26 pm
Name: Roger John Sweet

Re: Sky and weather but no image

Post by westhag1943 » Wed Apr 06, 2016 8:04 pm

Wally

Thanks for your reply.

The root does contain the .xml file.

The contents of the .ywl file are as follows:
<landscape id="weather_153EB5840E8" type="picture" name="weather">
<data src="yo_weather.png" horizonLevel="538"/>
</landscape>

Since my original post i have converted the .png image to a .swf, and this is in the weather folder. Should the data src in the .ywl now be changed to "yo_weather.swf? The instructions dont really make this clear.

User avatar
Wally©
Posts: 805
Joined: Sun Dec 12, 2010 2:18 am
Name: Walter

Re: Sky and weather but no image

Post by Wally© » Wed Apr 06, 2016 8:26 pm

It needs to be an .swf file instead of a .png...

Convert the file using the tool provided by this site...

http://yowindow.com/png_to_swf.php

Upload the .swf to your website and edit the .ywl file to point to the .swf...

Make sure that the horizon is properly aligned...
Wally©...

(Ignorance can easily be overcome...Stupidity is 4ever...)

westhag1943
Posts: 5
Joined: Wed Apr 06, 2016 4:26 pm
Name: Roger John Sweet

Re: Sky and weather but no image

Post by westhag1943 » Thu Apr 07, 2016 12:02 am

The .swf file was created using the tool on the website and has already been uploaded.

The data source in the .ywl file now points to the .swf file.

The horizon was aligned in YoWindow. In the .ywl file it says the horizonlevel is 538.

The landscape works ok in YoWindow but not in the weather widget. Interestingly the sky in the YoWindow landscape is mainly clear and starry, whereas the sky in the widget (both live forecasts for the Aldbourne location) is mainly cloudy. So one of them is wrong!

Any other suggestions?

User avatar
hermanz
Posts: 1886
Joined: Thu Apr 08, 2010 3:21 pm
Name: Herman
Location: Nieuwegein, Netherlands
Contact:

Re: Sky and weather but no image

Post by hermanz » Thu Apr 07, 2016 6:58 am

Hi Roger :good:

In the source I see landscape=http://www.berkshirevillages.co.uk/land ... eather.ywl.

But i cannot find this file

Where have you place the file crossdomain.xml
This is the right place http://www.berkshirevillages.co.uk/crossdomain.xml

Are you using IIS or apache ??


gr
Herman :beer:
(Wheather on an I(phone,pad,pod) or Android, YoWindow what else )

westhag1943
Posts: 5
Joined: Wed Apr 06, 2016 4:26 pm
Name: Roger John Sweet

Re: Sky and weather but no image

Post by westhag1943 » Thu Apr 07, 2016 1:08 pm

Hi Herman

crossdomain.xml is in the correct place.

I dont really understand your question about IIS or Apache but on trying to open both the .xml and the .ywl in my browser (Chrome) I get the message "The requested URL was not found on this server" and it says Apache/2.4.18 (Unix) Server at www.berkshirevillages.co.uk Port 80. So does that answer your question?

The .xml file and the landscapes folder have been uploaded and are listed on the remote server.

Roger

User avatar
Wally©
Posts: 805
Joined: Sun Dec 12, 2010 2:18 am
Name: Walter

Re: Sky and weather but no image

Post by Wally© » Thu Apr 07, 2016 1:22 pm

The files may be there...but they're inaccessible...

The crossdomain file must also be allowed to run in the root of the server...
Something most providers do not allow for 'security' reasons...

So...it seems to me the problem is at your end...

One of us could host the necessary files on our private server
so that at least the widget works properly on your website...

That is...until you figure out where the problem is...

(pm sent...check your inbox..)
Wally©...

(Ignorance can easily be overcome...Stupidity is 4ever...)

User avatar
Wally©
Posts: 805
Joined: Sun Dec 12, 2010 2:18 am
Name: Walter

Re: Sky and weather but no image

Post by Wally© » Thu Apr 07, 2016 7:11 pm

From the looks of it...it seems that you've figured it out...

Way to go !!!

Tip : There's only 1/3 of sky in the landscape...a 2/3 ratio is way better...
Wally©...

(Ignorance can easily be overcome...Stupidity is 4ever...)

westhag1943
Posts: 5
Joined: Wed Apr 06, 2016 4:26 pm
Name: Roger John Sweet

Re: Sky and weather but no image

Post by westhag1943 » Thu Apr 07, 2016 11:44 pm

Herman hit the nail on the head when he said that he couldnt see the files. He was actually right because I had got the domain name wrong. Berkshirevillages.co.uk instead of the correct berkshiredownsvillages.co.uk. Once that was corrected in the flashvars code the landscape image appeared in the widget.

Another problem now, and I actually drew attention to this earlier, is that the weather portrayed in the widget and in Yowindow for the same location (location ID 2657562, Aldbourne, UK) is entirely different. Currently the widget shows heavy rain and YoWindow shows a clear starry sky. And it is the widget that is wrong.

Does anyone have the answer to this?

Locked