Add your landscape to widget without crossdomain.xml

YoWindow widget Questions, Suggestions and Bugs
Registered users do not see the advertisments

Add your landscape to widget without crossdomain.xml

Postby par » Mon Dec 17, 2012 7:13 pm

Registered users do not see the advertisments
This is a quick solution for people who cannot upload crossdomain.xml to the root of web server.
The key is to upload the widget itself (I call this - standalone widget) to the server of your page.

How to add your own landscape to YoWindow widget without crossdomain.xml.

1. Download standalone widget .zip archive from YoWindow website.
http://yowindow.com/widget/yowidget_standalone.zip

2. Unzip yowidget_standalone.zip

3. Upload the contents of yowidget_standalone.zip to your website over FTP in binary mode.
To the directory of your choice.

Find yowidget.swf file, it is right at the top level.
This is the main application file.
Remember the path to yowidget.swf.

4. Test if the standalone widget is working properly.
There is a test page - example.html - in the package.
Navigate to example.html and check if the widget displayed correctly.

5. Customize YoWindow widget on the setup page
http://yowindow.com/weatherwidget

6. Copy HTML code and paste into some text editor.

7. Replace the path "http://swf.yowindow.com/yowidget3.swf" to the path to yowidget.swf on your server.
You need to do this 2 times in the widget code.

8. Upload your landscape to your server.
WARNING: you must to convert .png image to .swf.
Otherwise your users are not to be happy.

9. Edit widget HTML code - add "landscape" variable to flashvars value.
Set landscape to the path of landscape .ywl on your server.
Example:
... &landscape=http://repkin.ru/yo/standalone/new_york_landscape/New York City.ywl"

10. Upload your HTML page to the server and check it out.
If you have made it right, you should see your picture inside YoWindow widget.




Share |

YoWindow - weather widget, weather screensaver, desktop weather
Get YoWindow for your phone or tablet - it's awesome on both!

Image Image Image
User avatar
par
 
Posts: 7420
Joined: Mon Sep 21, 2009 11:56 am
Location: Saint-Petersburg, Russia
Registered users do not see the advertisments




Registered users do not see the advertisments

Re: Add your landscape to widget without crossdomain.xml

Postby hermanz » Mon Dec 17, 2012 9:24 pm

:good:



Share |
(Wheather on an I(phone,pad,pod) or Android, YoWindow what else )
User avatar
hermanz
 
Posts: 1864
Joined: Thu Apr 08, 2010 3:21 pm
Location: Nieuwegein, Netherlands
Registered users do not see the advertisments





Re: Add your landscape to widget without crossdomain.xml

Postby Don » Wed Dec 19, 2012 4:51 am

Hey Pavel,

Thanks for making this available. :good:

-------------------------

Here's a note for anyone who might have an older copy of the widget code:

7. Replace the path "http://swf.yowindow.com/wimo/hpPal/hpPal.swf" with the path to yowidget.swf on your server.
You need to do this 2 times in the widget code.

Don



Share |
Just some stuff that I find useful. --> http://home.surewest.net/donjr
User avatar
Don
 
Posts: 687
Joined: Tue Sep 14, 2010 12:14 am
Location: Roseville, California, United States of America
Registered users do not see the advertisments





Re: I cant go any further

Postby babisxt » Sat Aug 31, 2013 11:24 am

I have these 3 files.
I cant go any further.
Please if you can download these files and fix my Yowindow

Thanks



Share |
babisxt
 
Posts: 23
Joined: Sun Sep 27, 2009 10:54 am
Registered users do not see the advertisments





Re: Add your landscape to widget without crossdomain.xml

Postby qwertz » Sat Jan 25, 2014 5:58 am

OK, I am consistently getting a fireworks screen - not the Vancouver Airport as I requested. Getting frustrated. Any suggestions please?

Here is the website: http://www.lighthousememories.ca

Here is my code:

<div style="width:220px; height:150px;">
<object type="application/x-shockwave-flash" data="http://lighthousememories.ca/. . . /plugins/yowidget_standalone/yowidget.swf" width="220" height="150">
<param name="movie" value="http://lighthousememories.ca/. . . /plugins/yowidget_standalone/yowidget.swf"/>
<param name="allowfullscreen" value="true"/>
<param name="wmode" value="opaque"/>
<param name="bgcolor" value="#FFFFFF"/>
<param name="flashvars"
value="location_id=gn:6173331&amp;location_name=Vancouver&amp;landscape=http://lighthousememories.ca/. . . /plugins/yowidget_standalone/landscapes/airport.ywl&amp;time_format=12&amp;unit_system=metric&amp;background=#FFFFFF&amp;copyright_bar=false"
/>
<a href="http://WeatherScreenSaver.com?client=widget&amp;link=copyright"
style="width:220px;height:150px;display: block;text-indent: -50000px;font-size: 0px;background:#DDF url(http://yowindow.com/img/logo.png) no-repeat scroll 50% 50%;"
>Free Weather Widget</a>
</object>
</div>
<div style="width: 220px; height: 15px; font-size: 14px; font-family: Arial,Helvetica,sans-serif;">
<span style="float:left;"><a target="_top" href="http://WeatherScreenSaver.com?client=widget&amp;link=copyright" style="color: #2fa900; font-weight:bold; text-decoration:none;" title="Free Weather Widget">YoWindow.com</a></span>
<span style="float:right; color:#888888;"><a href="http://yr.no" style="color: #2fa900; text-decoration:none;">yr.no</a></span>
</div>



Share |
Last edited by qwertz on Wed Jan 29, 2014 10:14 pm, edited 1 time in total.
qwertz
 
Posts: 15
Joined: Wed Sep 21, 2011 7:53 pm
Registered users do not see the advertisments





Re: Add your landscape to widget without crossdomain.xml

Postby Don » Mon Jan 27, 2014 11:59 am

qwertz wrote:OK, I am consistently getting a fireworks screen - not the Vancouver Airport as I requested. Getting frustrated. Any suggestions please?

It looks like some of the components of YoWindow are mising. Please make sure you have uploaded all the files from the zip package to your server.

Don



Share |
Just some stuff that I find useful. --> http://home.surewest.net/donjr
User avatar
Don
 
Posts: 687
Joined: Tue Sep 14, 2010 12:14 am
Location: Roseville, California, United States of America
Registered users do not see the advertisments





Re: Add your landscape to widget without crossdomain.xml

Postby qwertz » Tue Jan 28, 2014 7:02 am

Hi Don, thanks for the reply. ALL the files were uploaded by FTP from my computer after I unzipped the ZIP file.


landscapes
4 KB
Jan 25, 2014 11:51 AM
httpd/unix-directory
0755

lang
4 KB
Jan 25, 2014 11:51 AM
httpd/unix-directory
0755

new_york_landscape
4 KB
Jan 25, 2014 11:51 AM
httpd/unix-directory
0755

swf
4 KB
Jan 25, 2014 11:51 AM
httpd/unix-directory
0755

example.html
1.19 KB
Jan 25, 2014 11:51 AM
text/html
0644

swfobject.js
24.97 KB
Jan 25, 2014 11:51 AM
text/x-generic
0644

yowidget.swf

But it still does not work. All the paths are correct, all the files are there, and yet nothing happens.



Share |
qwertz
 
Posts: 15
Joined: Wed Sep 21, 2011 7:53 pm
Registered users do not see the advertisments





Re: Add your landscape to widget without crossdomain.xml

Postby hermanz » Tue Jan 28, 2014 8:14 pm

Hi

The page www.lighthousememories.ca cannot be displayed.

Is the site off line

gr.
herman :beer:



Share |
(Wheather on an I(phone,pad,pod) or Android, YoWindow what else )
User avatar
hermanz
 
Posts: 1864
Joined: Thu Apr 08, 2010 3:21 pm
Location: Nieuwegein, Netherlands
Registered users do not see the advertisments





Re: Add your landscape to widget without crossdomain.xml

Postby qwertz » Tue Jan 28, 2014 10:59 pm

The site WAS offline due to server problems, but is online now.



Share |
qwertz
 
Posts: 15
Joined: Wed Sep 21, 2011 7:53 pm
Registered users do not see the advertisments





Re: Add your landscape to widget without crossdomain.xml

Postby ikarus1969 » Sat Feb 01, 2014 3:43 pm

If with "airport-landscape" you mean the built-in landscape then just code (in the flashvars-parameter)
Code: Select all
landscape=airport
and not
Code: Select all
landscape=....airport.ywl


Could you please try that and tell us if that helped out? Thank you!

edit: you find the list of widget-parameters here: http://yowindow.de/widget_parameters.php



Share |
»Man is impressive. In a universe full of untold secrets he has invented boredom.«
User avatar
ikarus1969
 
Posts: 1645
Joined: Wed Nov 18, 2009 9:58 am
Location: Vienna, Austria
Registered users do not see the advertisments





Next

Return to Widget for Site or Blog

Who is online

Users browsing this forum: No registered users and 2 guests

Registered users do not see the advertisments