Widget with own photo isn't working

YoWindow widget Questions, Suggestions and Bugs
Post Reply
DikkieDick
Posts: 2
Joined: Mon Jul 14, 2014 2:58 pm
Name: Dick

Widget with own photo isn't working

Post by DikkieDick » Mon Jul 14, 2014 3:02 pm

Hi, I followed the instructions, put a crossdomain.xml on the server-root with the following contents:

Code: Select all

<?xml version="1.0"?>
<!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
<cross-domain-policy>
<allow-access-from domain="*.yowindow.com" secure="true"/>
<allow-access-from domain="*.gmodules.com" secure="true"/>
</cross-domain-policy>
Put an IMG with size 1600x1155 on the server with a transparent sky. Created the widget in WP which looks like this:

Code: Select all

<div style="width:270px; height:160px;">
    <object type="application/x-shockwave-flash" data="http://swf.yowindow.com/yowidget3.swf" width="270" height="160">
    	<param name="movie" value="http://swf.yowindow.com/yowidget3.swf"/>
    	<param name="allowfullscreen" value="true"/>
    	<param name="wmode" value="opaque"/>
    	<param name="bgcolor" value="#FFFFFF"/>
    	<param name="flashvars" 
    	value="location_id=2973675&location_name=Wanneperveen&
amp;landscape=http://mcwanneperveen.nl/mcw/wp-content/yowindow/Schultenhuis_trans.ywl&time_format=24&unit_system=metric&lang=nl&background=#FFFFFF&copyright_bar=false"
    />
        <a href="http://WeatherScreenSaver.com?client=widget&link=copyright"
        style="width:240px;height:160px;display: block;text-indent: -50000px;font-size: 0px;background:#DDF url(http://yowindow.com/img/logo.png) no-repeat scroll 50% 50%;"
        >Weer Widget</a>
    </object>
</div>
<div style="width: 240px; height: 15px; font-size: 14px; font-family: Arial,Helvetica,sans-serif;">
	<span style="float:left;"><a target="_top" href="http://WeatherScreenSaver.com?client=widget&link=copyright" style="color: #2fa900; font-weight:bold; text-decoration:none;" title="Weer Widget">YoWindow.com</a></span>
	<span style="float:right; color:#888888;">Voorspelling : &nbsp;<a href="http://yr.no" style="color: #2fa900; text-decoration:none;">yr.no</a></span>
</div>
Files do exist and if I enter http://mcwanneperveen.nl/mcw/wp-content ... _trans.ywl it shows nicely the contents of this file and when I enter the swf-file it shows the picture, but the widget still shows the default village. What's wrong here?
Thanx in advance.

Greetings, Dick

User avatar
hermanz
Posts: 1887
Joined: Thu Apr 08, 2010 3:21 pm
Name: Herman
Location: Nieuwegein, Netherlands
Contact:

Re: Widget with own photo isn't working

Post by hermanz » Mon Jul 14, 2014 8:19 pm

Hi Dick :good:


Welcome to YoWindow

First i have added Wanneperveen to the location database. The id is 2745048
Can you change the content of crossdomain.xml with
<cross-domain-policy>
<allow-access-from domain="*" secure="true"/>
</cross-domain-policy>


do you want to send me the photo

gr.
Herman :beer:
(Wheather on an I(phone,pad,pod) or Android, YoWindow what else )

DikkieDick
Posts: 2
Joined: Mon Jul 14, 2014 2:58 pm
Name: Dick

Re: Widget with own photo isn't working

Post by DikkieDick » Mon Jul 14, 2014 9:42 pm

Herman,

Thanx. PM sent. The location_id I used was automatically filled, but modified crossdomain.xml and added the new location_id. One question: should the crossdomain.xml be in the root of the server or the root of the Wordpress-installation, which is in a subdirectory of the root. Also found yowidget_standalone, but I don't guess the problem lies in there. And uploading to this server isn't quite easy as I have to upload file by file. :-(
Update: FileZilla is working, so I'll give it a try with the standalone widget.
Another update: Using the standalone widget gives still the same result. :-(
Another update: with modified example.html http://mcwanneperveen.nl/mcw/wp-content ... ample.html it's working. So I am on the right track. ;-)

And another few tries later: YES! It's working.

BTW. Desktop-version is working.

Post Reply