Own picture in website widget

Feature discussion
keithfdean
Posts: 13
Joined: Wed Sep 08, 2010 1:18 pm
Name: Keith Dean

Re: Own picture in website widget

Post by keithfdean » Tue Sep 14, 2010 4:13 pm

Hi Par
I really appreciate your efforts to help me.
Getting my landscape into my widget is driving me crazy!

See images here . . . . . http://www.postimage.org/image.php?gallery=3Nvb2F and the website . . . . . www.casadiantonio.com
Image of my Landscape - works perfectly in my screensaver. No problems at all.
Image of my Application Support directory for YoWindows
Image of the YoWindows files on my server.
Image of the parameter file for the landscape.
The end result can be seen in the website. - No landscape!!!

I have no doubt that it is me. I am probably doing something stupid through oversight or inexperience.
Any help will be much appreciated
Regards
Keith

User avatar
par
Posts: 7820
Joined: Mon Sep 21, 2009 11:56 am
Name: Pasha
Location: Saint-Petersburg, Russia
Contact:

Re: Own picture in website widget

Post by par » Tue Sep 14, 2010 4:23 pm

Right now I see at least 2 problems

1. The landscape you have specified is not available
http://www.casadiantonio.com/yo_kdcasa_ ... _nosky.ywl

Try to put yo_kdcasa_nosky directory inside htdocs directory

2. You have a space before "landscape" parameter, remove it to let the widget read parameters.
[the space is here]&http://www.casadiantonio.com/yo_kdcasa_ ... _nosky.ywl
Get YoWindow weather app for your phone or tablet.

Image Image Image

keithfdean
Posts: 13
Joined: Wed Sep 08, 2010 1:18 pm
Name: Keith Dean

Re: Own picture in website widget

Post by keithfdean » Tue Sep 14, 2010 5:12 pm

Thanks Par
I made those changes. (removed the space in the param, and moved my landscape folder to htdocs)
Now the widget displays the name of the landscape while it is loading, but I still don't get the landscape appearing.
Could it have anything to do with the size of the widget?
Thanks
Keith

keithfdean
Posts: 13
Joined: Wed Sep 08, 2010 1:18 pm
Name: Keith Dean

Re: Own picture in website widget

Post by keithfdean » Tue Sep 14, 2010 5:33 pm

Just a follow-up Par
YoWindows appears to keep adding an additional 'yo' to my landscape filename in the Applications Support folder.
My file has changed from kdcasa_nosky.png to yo_kdcasa_nosky.png, to yo_yo_kdcasa_nosky.png, and is now yo_yo_yo_kdcasa_nosky.png
Is this a Mac version problem/feature?
Perhaps I should revert to Windows and start all over again?
Rgds
Keith

User avatar
par
Posts: 7820
Joined: Mon Sep 21, 2009 11:56 am
Name: Pasha
Location: Saint-Petersburg, Russia
Contact:

Re: Own picture in website widget

Post by par » Tue Sep 14, 2010 5:40 pm

In .ywl file you refer to yo_yo_kdcasa_nosky.png
But you should refer yo_kdcasa_nosky.png
After you make this change the landscape will hopefully appear.
Have not you considered converting .png to .swf to reduce file size significantly?

Yes, you better not to use Mac version until the final release.
Get YoWindow weather app for your phone or tablet.

Image Image Image

User avatar
hermanz
Posts: 1882
Joined: Thu Apr 08, 2010 3:21 pm
Name: Herman
Location: Nieuwegein, Netherlands
Contact:

Re: Own picture in website widget

Post by hermanz » Tue Sep 14, 2010 6:54 pm

Hi Keith

In the root of your website is a file crossdomain.xml.
the content of this file should be

<?xml version="1.0" ?>
<!DOCTYPE cross-domain-policy (View Source for full doctype...)>
- <cross-domain-policy>
<site-control permitted-cross-domain-policies="all" />
<allow-access-from domain="*" secure="true" />
<allow-http-request-headers-from domain="*" headers="*" secure="true" />
</cross-domain-policy>


gr.
Herman
(Wheather on an I(phone,pad,pod) or Android, YoWindow what else )

User avatar
par
Posts: 7820
Joined: Mon Sep 21, 2009 11:56 am
Name: Pasha
Location: Saint-Petersburg, Russia
Contact:

Re: Own picture in website widget

Post by par » Tue Sep 14, 2010 7:18 pm

Actually the file is ok, it is even better to compose it this way.

Initially I have posted a crossdomain.xml that is too much open (Herman has quoted it).
Later on I have published a better variant.
It allows the widgets on your site to connect to yowindow.com only.

See the section about crossdomain.xml in the new tutorial
http://yowindow.com/widget_and_landscape

And here is the file
http://yowindow.com/files/crossdomain.xml
Get YoWindow weather app for your phone or tablet.

Image Image Image

keithfdean
Posts: 13
Joined: Wed Sep 08, 2010 1:18 pm
Name: Keith Dean

Re: Own picture in website widget

Post by keithfdean » Tue Sep 14, 2010 10:07 pm

Oh dear. I can't believe the problems I'm having with this widget creation.
I have created a new version of my landscape on my virtual Windows XP machine.
Works perfectly. No problems. Now all I have to do is to put a crossdomain.xml file in my server, upload my landscape to the server, and amend the HTML parameters.
Sounds so simple.
I copied the crossdomain.xml you recommended.
I uploaded the landscape folder
I amended the parameters.
result? Weather but no landscape.
Could you advise - Do the parameters look OK in the source code of my webpage?
Is there anything else you can suggest?
Thanks
Keith

User avatar
par
Posts: 7820
Joined: Mon Sep 21, 2009 11:56 am
Name: Pasha
Location: Saint-Petersburg, Russia
Contact:

Re: Own picture in website widget

Post by par » Wed Sep 15, 2010 6:23 pm

That's simple.
The landscape will appear if you to follow the tutorial precisely.

1. You already have correct crossdomain.xml on your server, that's good :)
2. Make sure yo_kdcasa_nosky.ywl refers yo_kdcasa_nosky.png in src attribute
3. upload yo_kdcasa_nosky.png and yo_kdcasa_nosky.xml to the following directory
http://www.casadiantonio.com/yo_kdcasa_nosky/
4. add "landscape" variable to the widget with the following value
http://www.casadiantonio.com/yo_kdcasa_ ... _nosky.ywl

Must work.

Have not you considered converting .png to .swf to reduce file size significantly?
Get YoWindow weather app for your phone or tablet.

Image Image Image

keithfdean
Posts: 13
Joined: Wed Sep 08, 2010 1:18 pm
Name: Keith Dean

Re: Own picture in website widget

Post by keithfdean » Wed Sep 15, 2010 6:43 pm

Thanks Par
I know this should work
A few questions . . .
2. How do I make sure that yo_kdcasa_nosky.ywl refers to yo_kdcasa_nosky.png in the src attribute?
3. You suggest I upload yo_kdcasa_nosky.png and yo_kdcasa_nosky.xml. Where did the .xml file come from? Did you mean .ywl?
Once I finally get this working I will look at converting to .swf
Thnks
Keith

Post Reply