Problem with PWS Data on my website

Registered users do not see the advertisments

Problem with PWS Data on my website

Postby WeWe » Fri Jan 27, 2012 10:34 am

Registered users do not see the advertisments

Hello at all,
I always get an error message with the xml-file:
XML-Verarbeitungsfehler: Nicht definierte Entität
Adresse: http://wetter-westhausen.de/data/yowindow.xml
Zeile Nr. 10, Spalte 9: <temperature unit="&deg;C"/>
--------^


And my yowindow don´t show a temperature.

http://www.wetter-westhausen.de/test3.htm

Where is the problem?
I´ve changed one unit in my yo_cumulus.txt:
<feels_like value="<#apptemp>"/>
but I don´t think that this causes the problem.

Greetings
Joa



Share |

YoWindow - weather widget, weather screensaver, desktop weather
WeWe
 

Re: Problem with PWS Data on my website

Postby ikarus1969 » Fri Jan 27, 2012 11:04 am

WeWe wrote:Hello at all,
I always get an error message with the xml-file:
XML-Verarbeitungsfehler: Nicht definierte Entität
Adresse: http://wetter-westhausen.de/data/yowindow.xml
Zeile Nr. 10, Spalte 9: <temperature unit="&deg;C"/>
--------^


And my yowindow don´t show a temperature.

http://www.wetter-westhausen.de/test3.htm

Where is the problem?
I´ve changed one unit in my yo_cumulus.txt:
<feels_like value="<#apptemp>"/>
but I don´t think that this causes the problem.

Greetings
Joa

Hi joa(chim?)!

I think the problem is that the opening-temperature-tag has a closing slash which is wrong. The temperature tag has a closing tag of its own:

YoWindow - Cumulus - yowindow.xml.jpg
YoWindow - Cumulus - yowindow.xml.jpg (142.81 KiB) Viewed 2166 times


Could you please try to avoid creating this slash and tell us if you succeed at the end? Thank you!



Share |
»Man is impressive. In a universe full of untold secrets he has invented boredom.«
User avatar
ikarus1969
 
Posts: 1536
Joined: Wed Nov 18, 2009 9:58 am
Location: Vienna, Austria

Re: Problem with PWS Data on my website

Postby WeWe » Fri Jan 27, 2012 11:25 am

Hi Ikarus,
thank you for your reply.
Now I can see my weather, but still the error-message.
And the apparent-temp is not the temp from my PWS.

Is this correct:
<feels_like value="<#apptemp>"/>

or should I type the "RC" in the tag <#apptemp>?
=> <feels_like value="<#RCapptemp>"/>


Thx
Joa(chim)



Share |
WeWe
 

Re: Problem with PWS Data on my website

Postby ikarus1969 » Fri Jan 27, 2012 12:19 pm

WeWe wrote:Hi Ikarus,
thank you for your reply.
Now I can see my weather, but still the error-message.
And the apparent-temp is not the temp from my PWS.

Is this correct:
<feels_like value="<#apptemp>"/>

or should I type the "RC" in the tag <#apptemp>?
=> <feels_like value="<#RCapptemp>"/>


Thx
Joa(chim)

As i don't have a PWS nor do i use Cumulus i had a look at the yo_cumulus.txt which is provided in the instructions and - as you said in your initial post - there's a difference (at least one) to the one you are using. Does it work (does the error disappear) if you use the values from the default txt-file?

Code: Select all
        <temperature unit="<#tempunit>">
           <current value="<#RCtemp>"/>
           <feels_like value="<#RCwchill>"/>
        </temperature>




Share |
»Man is impressive. In a universe full of untold secrets he has invented boredom.«
User avatar
ikarus1969
 
Posts: 1536
Joined: Wed Nov 18, 2009 9:58 am
Location: Vienna, Austria

Re: Problem with PWS Data on my website

Postby WeWe » Fri Jan 27, 2012 12:30 pm

The same error-message in the xml-file with the original txt-file. :(
I need the apparent temp and not the windchill, because the "gefühlte Temperatur" is the apparent (includes the windchill)



Share |
WeWe
 

Re: Problem with PWS Data on my website

Postby ikarus1969 » Fri Jan 27, 2012 12:38 pm

WeWe wrote:The same error-message in the xml-file with the original txt-file. :(
I need the apparent temp and not the windchill, because the "gefühlte Temperatur" is the apparent (includes the windchill)

So Joachim, at this point i have to give up and hope some other user who has Cumulus running successfully will provide help.
I'm sorry! :unknown: (german "Was Cumulus anlangt, bin ich mit meinem Latein am Ende")



Share |
»Man is impressive. In a universe full of untold secrets he has invented boredom.«
User avatar
ikarus1969
 
Posts: 1536
Joined: Wed Nov 18, 2009 9:58 am
Location: Vienna, Austria

Re: Problem with PWS Data on my website

Postby WeWe » Fri Jan 27, 2012 12:43 pm

Trotzdem danke!



Share |
WeWe
 

Re: Problem with PWS Data on my website

Postby WeWe » Fri Jan 27, 2012 6:18 pm

I did a few changes on the txt-file.
The line:
<feels_like value="<#RCwchill>"/>
didn´t have any effect.
When I changed for example
<current value="<#RCtemp>"/>
into
<current value="<#RChum>"/>
I got the 88% as 88°C
and the windchill temp was 772 !!! and not the real Temp (for example -1 °C)

Who can help me?? :( :(



Share |
WeWe
 


Return to Cumulus

Who is online

Users browsing this forum: No registered users and 1 guest

Registered users do not see the advertisments