do not see anything (using PWS and Weather Display)

Personnal Weather Station (PWS) support
Post Reply
nikbxos73
Posts: 8
Joined: Thu Nov 21, 2013 7:30 pm
Name: Nikos

do not see anything (using PWS and Weather Display)

Post by nikbxos73 » Mon Nov 25, 2013 7:45 pm

I wanted to put my station using Weather Display does not work.
Here is the link: http://weatherpantokratoras.blogspot.it/

and html

Code: Select all

<div style="width:600px; height:480px;">
    <object type="application/x-shockwave-flash" data="http://swf.yowindow.com/yowidget3.swf" width="600" height="480">
    	<param name="movie" value="http://swf.yowindow.com/yowidget3.swf"/>
    	<param name="allowfullscreen" value="true"/>
    	<param name="wmode" value="opaque"/>
    	<param name="bgcolor" value="#FFFFFF"/>
    	<param name="flashvars" 
    	value="location_id=gn:2463612&current_weather_url=http://www.pwsweather.com/obs/REBOX73.html#"/>
        <a href="http://WeatherScreenSaver.com?client=widget&link=copyright"
        style="width:220px;height:150px;display: block;text-indent: -50000px;font-size: 0px;background:#DDF url(http://yowindow.com/img/logo.png) no-repeat scroll 50% 50%;"
        >Καιρικό Widget</a>
    </object>
</div>
<div style="width: 220px; height: 15px; font-size: 14px; font-family: Arial,Helvetica,sans-serif;">
	<span style="float:left;"><a target="_top" href="http://WeatherScreenSaver.com?client=widget&link=copyright" style="color: #2fa900; font-weight:bold; text-decoration:none;" title="Καιρικό Widget">YoWindow.com</a></span>
	<span style="float:right; color:#888888;"><a href="http://yr.no" style="color: #2fa900; text-decoration:none;">yr.no</a></span>
</div>
Please help meeeee!!!!?????
Last edited by ikarus1969 on Tue Nov 26, 2013 9:43 am, edited 1 time in total.
Reason: embedded html-code in [code]-tag

jmcmurry
Posts: 367
Joined: Tue Oct 13, 2009 11:09 am
Name: Jim
Location: Mauston, WI, USA
Contact:

Re: do not see anything (using PWS and Weather Display)

Post by jmcmurry » Mon Nov 25, 2013 9:03 pm

nikbxos73,

I don't see reference to the yowindow.xml file that Weather Display creates. There are also some other things in your code that I don't understand. I think the best thing would be for you to start over and follow the instructions at http://yowindow.com/help.php#q8. The instructions for how to get Weather Display to create the yowindow.xml file are at http://yowindow.com/pws_weather_display.php. Then when you get the widget working, additional parameters to customize the widget are available at http://yowindow.com/widget_parameters.php.

Start slow and take it a step at a time, then the Widget will work for you.

Good Luck. - Jim

nikbxos73
Posts: 8
Joined: Thu Nov 21, 2013 7:30 pm
Name: Nikos

Re: do not see anything (using PWS and Weather Display)

Post by nikbxos73 » Tue Dec 03, 2013 6:36 pm

1.png
Hi all,
I followed the tutorial and still can't get it right.
The XML file is being generated and uploaded to my website.

here is the <object code I have been playing with.

Code: Select all

<object type="application/x-shockwave-flash" data="http://swf.yowindow.com/wimo/hpPal/hpPal.swf" width="280" height="194">
<param name="movie" value="http://swf.yowindow.com/wimo/hpPal/hpPal.swf"/>
<param name="allowfullscreen" value="true"/>
<param name="wmode" value="opaque"/>
<param name="bgcolor" value="#FFFFFF"/>
<param name="flashvars" value="location_id=gn:2463612&current_weather_url=http://pantokratoras-kerkyra.meteoclub.gr/&time_format=24&unit_system=metric&background=#FFFFFF&copyright_bar=false"/></object>
What did I miss ?????

my site weather is http://pantokratoras-kerkyra.meteoclub.gr/

my programm weather is Cumulus

Please you see my 4 pictures and my e-mail is nikbxos@yahoo.gr

Thank you and i am waiting for your message!
Nikos from Pantokratora Kerkyras
Attachments
2.5.png
02.png
Last edited by ikarus1969 on Thu Dec 05, 2013 10:31 am, edited 1 time in total.
Reason: please use code-tags for posting html- or xml- or any other code. thank you.

jmcmurry
Posts: 367
Joined: Tue Oct 13, 2009 11:09 am
Name: Jim
Location: Mauston, WI, USA
Contact:

Re: do not see anything (using PWS and Weather Display)

Post by jmcmurry » Tue Dec 03, 2013 7:23 pm

Nikos,

I see two problems. current_weather_url=http://pantokratoras-kerkyra.meteoclub.gr/ needs to reference your yowindow.xml so that should be

http://pantokratoras-kerkyra.meteoclub.gr/yowindow.xml

The other problem is that there is a problem with that file http://pantokratoras-kerkyra.meteoclub.gr/yowindow.xml so you'll need to figure out why. It looks to me like there is the degree symbol when there shouldn't be (&deg;). Once you fix that, keep trying that url until it shows with no errors.

- Jim

nikbxos73
Posts: 8
Joined: Thu Nov 21, 2013 7:30 pm
Name: Nikos

Re: do not see anything (using PWS and Weather Display)

Post by nikbxos73 » Tue Dec 03, 2013 9:09 pm

Jim.. Please now you see for my 3 screenshots and whose is errors??? Thanks
Attachments
2.png
02.png
This ok or not?
1.png
This is OK?

jmcmurry
Posts: 367
Joined: Tue Oct 13, 2009 11:09 am
Name: Jim
Location: Mauston, WI, USA
Contact:

Re: do not see anything (using PWS and Weather Display)

Post by jmcmurry » Tue Dec 03, 2013 9:33 pm

Nikos,

In your widget code that is see, you are telling it to use the file yocumulus.html. YoWindow needs to read an .xml file, not that one. Change that to yowindow.xml.

But your http://pantokratoras-kerkyra.meteoclub.gr/yowindow.xml that you should be using still has that error in it. If Cumulus is putting the degree (&deg;) symbol in there, you'll need to figure out how to stop it from doing that. If you have put a degree symbol in there, you'll need to remove it.

- Jim

jmcmurry
Posts: 367
Joined: Tue Oct 13, 2009 11:09 am
Name: Jim
Location: Mauston, WI, USA
Contact:

Re: do not see anything (using PWS and Weather Display)

Post by jmcmurry » Tue Dec 03, 2013 9:43 pm

Nikos,

I'm sorry, I got confused about Cumulus because you had that file name in your widget. I remember now that you are using Weather Display. I just looked in the FAQs and in the WD section I found what you need:
If you find the characters &deg; in your temperature or wind direction, in WD go to Control Panel - Web Files/Web Page Setup, then the Custom Web Page Setup tab. If the third item down "Include Units Used" is ticked, un-tick that.
Then you yowindow.xml file should parse correctly.

- Jim

nikbxos73
Posts: 8
Joined: Thu Nov 21, 2013 7:30 pm
Name: Nikos

Re: do not see anything (using PWS and Weather Display)

Post by nikbxos73 » Wed Dec 04, 2013 2:33 am

I'M SORRY I DO NOT USING THE WD (WEATHER DISPLAY)

I USE THE CUMULUS !!!!!

OH, MY GOD! WHY???? HOW WORK THE WEATHER WIDGET...

PLEASE LOOK SCEERNSHOT THAT I USING THE CUMULUS .........!!!!!!!!!!!!!!!

I WANT SALVATION !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Attachments
02.png

jmcmurry
Posts: 367
Joined: Tue Oct 13, 2009 11:09 am
Name: Jim
Location: Mauston, WI, USA
Contact:

Re: do not see anything (using PWS and Weather Display)

Post by jmcmurry » Wed Dec 04, 2013 11:24 am

Nikos,

I thought WD because of the name of this thread where you've posted. In your last screen shot It shows that you should be uploading a file named http://pantokratoras-kerkyra.meteoclub. ... mulus.html but that file seems to be empty. Somehow you need to get a valid xml file created for YoWindow to use.

I'm sorry but I don't use that program. If the Cumulus section of the YoWindow FAQs can't help you, http://yowindow.com/pws_cumulus.php then maybe someone else here will know the answer. Or maybe ask on the Cumulus forum why you cannot get a good yowindow.xml file created.

- Jim

Post Reply