no weather

jmcmurry
Posts: 366
Joined: Tue Oct 13, 2009 11:09 am
Name: Jim
Location: Mauston, WI, USA
Contact:

Re: no weather

Post by jmcmurry » Wed Nov 30, 2011 12:30 pm

Alessandro,

I have responded to this problem on the WD forum and hopefully that will fix things. It was wrong url, .php instead of .xml.

- Jim

i_fiorentino

Re: no weather

Post by i_fiorentino » Wed Nov 30, 2011 3:58 pm

Hi Jim,
the issue in not the wrong file....but other....that i don't still know.
I had already tried to change the path to yowindow.xml file but without success!
Regards,

Alessandro

User avatar
hermanz
Posts: 1883
Joined: Thu Apr 08, 2010 3:21 pm
Name: Herman
Location: Nieuwegein, Netherlands
Contact:

Re: no weather

Post by hermanz » Wed Nov 30, 2011 9:18 pm

Hi Alessandro :good:

compare mine source

<?xml version="1.0" encoding="UTF-8" ?>
- <response>
- <current_weather>
- <temperature>
<current value="5.7" />
<feels_like value="1.8" />
</temperature>
<humidity value="81" />
<pressure value="1021.4" />
<visibility value="16.5" unit="km" />
- <wind>
<speed value="21" unit="kph" />
<direction value="248" />
</wind>
- <sky>
- <precipitation>
- <rain>
<rate value="0.0" />
<daily_total value="1.0" />
</rain>
</precipitation>
<description value="onbewolkt" />
</sky>
<uv value="14" />
<solar radiation="200 W/m2" energy="11 kLUX" />
</current_weather>
</response>


with your source

- <response>
- <current_weather>
<temperature value="8.2" />
<humidity value="82" />
<pressure value="1028.2" />
- <wind>
<speed value="0.0" unit="kph" />
<direction value="40" />
</wind>
- <sky>
<icon id="1" format="wd" />
<description value="Nessun fenomeno" />
- <precipitation>
<rain rate="0.0" daily_total="0.0" />
</precipitation>
</sky>
</current_weather>
</response>


the good result is : http://hermanz.nl/index.php/nl/weer-ani ... -culemborg
gr.
herman :beer:
(Wheather on an I(phone,pad,pod) or Android, YoWindow what else )

jmcmurry
Posts: 366
Joined: Tue Oct 13, 2009 11:09 am
Name: Jim
Location: Mauston, WI, USA
Contact:

Re: no weather

Post by jmcmurry » Thu Dec 01, 2011 12:52 pm

Herman,

That particular xml is produced by the Weather Display program, but he has tried the .php script too. He has re-installed the widget code and now I've asked him to update his crossdomain.xml file. Any other ideas?

- Jim

User avatar
hermanz
Posts: 1883
Joined: Thu Apr 08, 2010 3:21 pm
Name: Herman
Location: Nieuwegein, Netherlands
Contact:

Re: no weather

Post by hermanz » Thu Dec 01, 2011 3:09 pm

Hi Jim :good:

I have 2 xml's
http://hermanz.nl/yowindow1.xml
http://hermanz.nl/yowindow2.xml
the difference between these

<sky>
<precipitation>
</precipitation>
</sky>


yowindow1.xml is without these code and gives an error
the results is http://hermanz.nl/index.php/nl/weer-ani ... -culemborg

gr.
herman :beer:
(Wheather on an I(phone,pad,pod) or Android, YoWindow what else )

i_fiorentino

Re: no weather

Post by i_fiorentino » Thu Dec 01, 2011 3:47 pm

So,
what could i do to fix my issue? :(
Thanks in advance,

Alessandro

Edit 08.47pm UTC+1 :

Thanks to all for your support :) :)
I probably had an older version of crossdomain.xml.
I've just updated it and yowindow screen works ok now.
http://www.meteocarmignano.it/wxysforecast.php

Thanks again,

Alessandro

jmcmurry
Posts: 366
Joined: Tue Oct 13, 2009 11:09 am
Name: Jim
Location: Mauston, WI, USA
Contact:

Re: no weather

Post by jmcmurry » Thu Dec 01, 2011 11:02 pm

Alessandro reported on the WD forum that his problem was fixed by updating his crossdomain.xml file.

- Jim

Post Reply